Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-15674

Object relation attributes pointing to hidden content objects cause a fatal error when updating search index (Oracle)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0.5
    • Fix Version/s: Customer request
    • Component/s: Database related, Search
    • Labels:
      None
    • Environment:

      eZ Publish 4.0.5
      Oracle 10g
      Solaris

      Description

      When publishing a content object that has an attribute of type object relation and a hidden content object as the value for this attribute, the publishing process will fail with a fatal error if delayed search indexing is DISABLED:

      Notice: Undefined index: 0 in kernel/search/plugins/ezsearchengine/ezsearchengine.php on line 319
      Undefined index: 0 in kernel/search/plugins/ezsearchengine/ezsearchengine.php on line 314
      Fatal error: A database transaction in eZ Publish failed.

      The object relation attribute is configured as follows:

      required: not checked
      searchable: checked
      switch of translation: not checked
      selection method: browse
      no preselected element
      allow fuzzy match: not checked

      eZ Support could not reproduce it on MySQL.

      Steps to reproduce

      1. Disable delayed indexing
      2. Create a class having an attribute of type object relation
      3. Create a content object of that class
      4. Select a hidden content object as a value for the object relation attribute
      5. Publish the content object

        Activity

        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


          People

          • Assignee:
            unknown
            Reporter:
            Jostein- Knudsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: