Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-15146

eZXMLText::outputHandler never returns eZPDFXMLOutput

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 4.1.3
    • Fix Version/s: 4.3.0beta1, Customer request
    • Labels:
      None
    • Environment:

      Operating System: All
      PHP Version: (please be specific, like '4.4.3' or '5.1.5') All
      Database and version: All
      Browser (and version): All

      Description

      This method is used by the standard ezxml datatype's template for PDF view, but can't return proper output handler for PDF (see /kernel/classes/datatypes/ezxmltext/ezxmltext.php:153).
      It seems that it comes from the code refactoring 4.0 -> 4.1 as the second parameter ($type) of this method is now unused in its code.

      This cause PDF view to have ezxml attributes with eZHTMLXMLOutput handler, wich make them appear with html tags.

      Steps to reproduce
      • Create an object with an "XML Block" attribute.
      • Fill this attribute with some html formated text
      • Publish it
      • View it with pdf view (content/pdf/<node id>)

        Activity

        André R added a comment -

        In reply to comment #048941
        Because PDFOutput / content/pdf is deprecated(cause it's latin1 only), and this is not a easy fix.
        So unless someone provides a patch for this issue, it will stay unfixed.

        Here's a thread on alternatives to generate pdf output:
        http://share.ez.no/forums/developer/pdf-export2

        Pierre Martel added a comment -

        But you've made a patch who seems to work..

        André R added a comment - - edited

        In reply to comment #048943
        Yes, but think it had some regressions.
        Think it caused issues for ezoe, but I'll need to retest it to remember what though.

        EDIT: Seems to be fine, will look into getting it fixed sooner rather then later.

        André R added a comment -

        Fixed in
        trunk (4.3.0beta1) rev. 24909

        Will consider merging this to 4.2 and 4.1 when QA has done it's testing on beta1.

        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


          People

          • Assignee:
            André R
            Reporter:
            Marc Sallaberremborde
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: