Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.0.5, 4.1.2
    • Fix Version/s: Customer request
    • Component/s: Language
    • Labels:
      None

      Description

      ezlupdate is currently based on Qt 4.0, which is old (june 2005), and the code does not compile against the current 4.5 version of Qt. Also, if you use the linguist program from current Qt it will add extra information to the .ts-file which will subsequently be stripped away by ezlupdate.

      The attached source package contains my suggested implementation of ezlupdate based on Qt 4.5. Quite a few things have changed. The main.cpp is rewritten to support the API changes in Qt. The new API is bundled instead of the old one. The build system (.pro-file and supporting files) is also changed according to current Qt.

      I suggest that the current implementations in svn (support/ezlupdate and support/ezlupdate-qt4) are kept, and that we add this as support/ezlupdate-qt4.5. We may consider removing the version for Qt 3 (support/ezlupdate) or renaming it to support/ezlupdate-qt3.

      I have tested this on translations in trunk, and have seen no problems with it.

      1. ezlupdate-qt4.5.tar.gz
        120 kB
        (inactive) Gunnstein Lye

        Activity

        Hide
        (inactive) Gunnstein Lye added a comment -

        Renamed support/ezlupdate to support/ezlupdate-qt3 to clarify qt version, in
        trunk (4.2.0Alpha1) Rev. 23781
        stable/4.1 (4.1.4) Rev. 23782
        stable/4.0 (4.0.7) Rev. 23783

        Show
        (inactive) Gunnstein Lye added a comment - Renamed support/ezlupdate to support/ezlupdate-qt3 to clarify qt version, in trunk (4.2.0Alpha1) Rev. 23781 stable/4.1 (4.1.4) Rev. 23782 stable/4.0 (4.0.7) Rev. 23783
        Hide
        Alexandre Nion added a comment -

        Thanks for this new update!

        Just a small note about the ReadMe file that should also be adapted to take care of the new directory structure.
        Seems that the location of ezlupdate.pro is now changed, then :

        cd support/ezlupdate-qt4.5

        should become

        support/ezlupdate-qt4.5/ezlupdate

        Show
        Alexandre Nion added a comment - Thanks for this new update! Just a small note about the ReadMe file that should also be adapted to take care of the new directory structure. Seems that the location of ezlupdate.pro is now changed, then : cd support/ezlupdate-qt4.5 should become support/ezlupdate-qt4.5/ezlupdate
        Hide
        (inactive) Gunnstein Lye added a comment -

        In reply to comment #048695
        I'll update that info. Thanks!

        Show
        (inactive) Gunnstein Lye added a comment - In reply to comment #048695 I'll update that info. Thanks!
        Hide
        (inactive) Gunnstein Lye added a comment -

        In reply to comment #048696
        Done in
        trunk (4.2.0Alpha1) Rev. 23832
        stable/4.1 (4.1.4) Rev. 23833
        stable/4.0 (4.0.7) Rev. 23834

        Show
        (inactive) Gunnstein Lye added a comment - In reply to comment #048696 Done in trunk (4.2.0Alpha1) Rev. 23832 stable/4.1 (4.1.4) Rev. 23833 stable/4.0 (4.0.7) Rev. 23834
        Hide
        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

        Show
        ezrobot added a comment - This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          People

          • Assignee:
            Unassigned
            Reporter:
            (inactive) Gunnstein Lye
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: