Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-12655

Variable Repository in [FlagIcons] doesn't seem to be used

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 3.10.0, 4.0.0
    • Fix Version/s: 4.3.0beta1
    • Component/s: Misc
    • Labels:
      None
    • Environment:

      Operating System: Unix
      PHP Version: 5.2.0
      Database and version: MySQL 5
      Browser (and version):

      Description

      Hi,

      I have created an extension to change the icons and I have changed the Repository of IconSettings.

      The problem is that the flag icons have disappeared.

      But in icon.ini there is an option [FlagIcons] Repository. Without changing that option I thought it wouldn't change the path for the flag icons.

      I checked in the kernel (ezwordtoimageoperator.php):

      case 'flag_icon':
                  {
                      $ini = eZINI::instance( 'icon.ini' );
                      $repository = $ini->variable( 'IconSettings', 'Repository' );
                      $theme = $ini->variable( 'FlagIcons', 'Theme' );
      

      I think $repository doesn't have to be read in [IconSettings] but in [FlagIcons] or the variable Repository in [FlagIcons] is useless and should be removed to avoid confusions.

      Steps to reproduce

      Change icon.ini

      [FlagIcons]

      1. Where to look for flag icons, relative to eZ Publish
        Repository=share/icons

      The path of the flag icons doesn't change

        Attachments

          Activity

            People

            Assignee:
            andre1 André R
            Reporter:
            dvasconc Dominique De Vasconcelos
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: