Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-12180

Errors appear when trying to copy subtree with sensitive menu

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: 4.0.0rc1
    • Fix Version/s: None
    • Component/s: Database related
    • Labels:
      None

      Description

      When I trying to copy subtree with sensitive menu several errors appear:

      Error: eZOracleDB Dec 05 2007 11:29:54

      Error (12899): ORA-12899: value too large for column
      "VV"."EZSEARCH_WORD"."WORD" (actual: 179, maximum: 150)
      Failed query at offset 118:
      INSERT INTO
      ezsearch_word ( word, object_count )
      VALUES ( 'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa', '1' )

      Start of error:
      'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa', '1' )

      Error: eZOracleDB Dec 05 2007 11:29:54
      Error (8002): ORA-08002: sequence S_SEARCH_WORD.CURRVAL is not yet defined in this session
      Failed query at offset 0:
      SELECT s_search_word.currval from DUAL
      Start of error:
      SELECT s_search_word.currval from DUAL

      Error: eZOracleDB Dec 05 2007 11:29:54
      Error (1400): ORA-01400: cannot insert NULL into ("VV"."EZSEARCH_OBJECT_WORD_LINK"."NEXT_WORD_ID")
      Failed query at offset 649:
      INSERT INTO
      ezsearch_object_word_link
      ( word_id,
      contentobject_id,
      frequency,
      placement,
      next_word_id,
      prev_word_id,
      contentclass_id,
      contentclass_attribute_id,
      published,
      section_id,
      identifier,
      integer_value )
      VALUES ( '1661', '225', '0', '2', '', '1660', '16', '186', '1196846993', '1', 'intro', '0' )
      Start of error:
      '', '1660', '16', '186', '1196846993', '1', 'intro', '0' )

      Error: eZOracleDB Dec 05 2007 11:29:54
      Error (1400): ORA-01400: cannot insert NULL into ("VV"."EZSEARCH_OBJECT_WORD_LINK"."WORD_ID")
      Failed query at offset 624:
      INSERT INTO
      ezsearch_object_word_link
      ( word_id,
      contentobject_id,
      frequency,
      placement,
      next_word_id,
      prev_word_id,
      contentclass_id,
      contentclass_attribute_id,
      published,
      section_id,
      identifier,
      integer_value )
      VALUES ( '', '225', '0', '3', '86', '1661', '16', '187', '1196846993', '1', 'body', '0' )
      Start of error:
      '', '225', '0', '3', '86', '1661', '16', '187', '1196846993', '1', 'body', '0' )

      Error: eZOracleDB Dec 05 2007 11:29:54
      Error (1400): ORA-01400: cannot insert NULL into ("VV"."EZSEARCH_OBJECT_WORD_LINK"."PREV_WORD_ID")
      Failed query at offset 653:
      INSERT INTO
      ezsearch_object_word_link
      ( word_id,
      contentobject_id,
      frequency,
      placement,
      next_word_id,
      prev_word_id,
      contentclass_id,
      contentclass_attribute_id,
      published,
      section_id,
      identifier,
      integer_value )
      VALUES ( '86', '225', '0', '4', '86', '', '16', '191', '1196846993', '1', 'publish_date', '0' )
      Start of error:
      '', '16', '191', '1196846993', '1', 'publish_date', '0' )

      Steps to reproduce
      • Create 2 objects (e.g. articles - first and second). In first article field "summary" or "body" should content word consists more then 150 characters.
      • Choose copy subtree in "First" sensitive menu and then select the second created article

        Issue Links

          Activity

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              unknown
              Reporter:
              Vyacheslav Voloshin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: