Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-11199

Importing content classes from package fails to create class names properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: 3.10.0alpha1, 3.9.2
    • Fix Version/s: 3.10.0
    • Component/s: Legacy > Packages
    • Labels:
      None
    • Environment:

      Operating System: N/A
      PHP Version: 4.4.7
      Database and version: N/A
      Browser (and version): N/A

      Description

      If you export a package of custom classes, remove the custom classes and import the exported package of custom classes ... the names of the classes and attributes are corrupt, blank or 'always-available'.

      Steps to reproduce

      1) export a package of custom classes
      2) remove the custom classes
      3) import the exported package of custom classes
      4) review the names of the imported custom classes
      5) notice the class name and class attribute names are corrupt, blank or 'always-available'.

        Issue Links

          Activity

          Brookins Consulting added a comment -

          This issue may be similar or even related to #11098,
          http://issues.ez.no/IssueView.php?Id=11098&activeItem=7

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              Vyacheslav Voloshin
              Reporter:
              Brookins Consulting
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: