Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-11080

eZ Publish Email Validation Excludes Google Mail Wildcards from Approved Email Validation Codes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 3.9.2
    • Fix Version/s: 3.10.0alpha1, 3.8.9, 3.9.3
    • Labels:
      None
    • Environment:

      Operating System: N/A
      PHP Version: N/A
      Database and version: N/A
      Browser (and version): N/A

      Description

      eZ Publish Email Validation Excludes Google Mail Wild cards from Approved Email Validation as invalid input.

      Example #0: thekracker+ezpedia@gmail.com
      Example #1: thekracker+iHaveAnEzTatooOnMyUpperLeftShoulder@gmail.com

      Is a valid email I could send email too yet eZ Publish email input validation (Re: ezmail)

      I have applications where I wish to accept email addresses with +string within the email (A wildcard / label) as valid email input, yet this feature (all be it new from google in the past few years) is not supported but it seems like such a small change to allow these email addresses as valid input.

      Here is some info about this feature,

      From: http://lifehacker.com/software/gmail/instant-disposable-gmail-addresses-144397.php

      `Let's say you need to sign up for a mailing list that interests you, but you're afraid spammers might get your address. We'll call the list "exoticflowers". Sign up with the list using the address "johndoe+exoticflowers@gmail.com". Email to that address will still come to your "johndoe@gmail.com" address even though the "To:" will include that "+exoticflowers" in it.

      Then set up Gmail filters to shuttle that +exoticflowers email past the inbox to a specific label. Neat.`

      I and my friends use this feature all the time, yet sadly, a few web sites / cms frameworks do not understand or support this input as a valid email address ... when they should consider the benefits it offers without detracting from existing validation rules.

      There are a large number of articles on and in support of this feature world wide!
      http://www.google.com/search?q=+disposable+Gmail+addresses

      Please update the validation to support this feature!

      eZUserType uses eZMail::validate()

      Respectfully,
      Brookins Consulting

      "Re: google gmail email address validation, labels, filters, wild cards, wildcards"

      Steps to reproduce

      Try to register an email address with the '+' character in the email address within eZ Publish 3.10 ... it fails citing the input as invalid.

        Issue Links

          Activity

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          Dmitry Lakhtyuk added a comment -

          Looks like several '+' are also allowed. I've made fix for that as well.
          Fixed in:
          trunk(3.10.0alpha1) rev. 19398,
          stable/3.9 (3.9.3) rev. 19399,
          stable/3.8 (3.8.9) rev. 19400

          Andrew Duck added a comment -

          This looks like an interesting and useful addition to the email validation code. I agree that such support should be added to the email validation code to support changing trends in the use of email.

          Regards,

          Andrew.

          Brookins Consulting added a comment - - edited

          We've added a patch (above) which extends the existing regular expression to allow for successful validation of info+eZPublishTag@gmail.com 'style' of email addresses.

          This patch is based on svn trunk rev 19277

          // kracker added a comment -

          Interesting related conversation on this subject in the comments of this page,
          http://info.netxpect.com/2007/04/php-mass-mail-checker.html

          //kracker

          Sole : Respect Pt3

          // Heath added a comment -

          I have added a forum conversation on ez.no to discuss and collect support for this feature. Please show your support!

          http://ez.no/community/forum/suggestions/ez_publish_email_validation_excludes_google_mail_wildcards

          Respectfully,
          Heath


            People

            • Assignee:
              Dmitry Lakhtyuk
              Reporter:
              Brookins Consulting
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: