Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-10635

email validation doesn't accept the + character

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: 3.9.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Description

      The + character is used as an address extension, for example user+foo@somewhere.com (see man-page for the postfix aliases file). However email addresses using the + doesn't validate.

        Issue Links

          Activity

          Vyacheslav Voloshin added a comment -

          Hi,
          it's not a bug, it must be so.

          Leif Arne Storset added a comment -

          Could Vyacheslav Voloshin perhaps provide the reason that the + character is not accepted by eZ publish? Maybe the + character breaks some other component in eZ publish, so that the e-mail validator must preemptively block e-mail addresses using plus addressing?

          Plus addressing is not very common in the general population, but I think a widely used platform such as eZ should support it.

          Jonas Maurus added a comment - - edited

          The "Plus" character, as well as many other "special" characters are valid parts of the local part of an email address as defined in RFC3696 http://www.faqs.org/rfcs/rfc3696.html.

          I think ezPublish should fully support all valid email addresses. http://www.regular-expressions.info/email.html provides a good reference. It's a hard problem to solve, unfortunately.

          Hence, I'd like you to reopen the bug, if there isn't a good reason for not doing so.

          Leif Arne Storset added a comment -

          I would also encourage reopening this issue.

          Kristof Coomans added a comment - - edited

          Was fixed here: http://issues.ez.no/IssueView.php?Id=11080, so closing.

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              unknown
              Reporter:
              Atle Pedersen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: