Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-841

EzRecommendationBundle v1.0.1 PHP version requirements

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 5.4
    • Fix Version/s: 1.4.1
    • Component/s: eZ Recommendation
    • Labels:
      None

      Description

      In EzRecommendationBundle github page states that the requirement for PHP version is 5.4.4.

      However EzRecommendationBundle v1.0.1 requires PHP version 5.5.0 at least due to a depency of guzzlehttp/guzzle

      full composer update error:

      Your requirements could not be resolved to an installable set of packages.
       
        Problem 1
          - ezsystems/recommendation-bundle v1.0.1 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0].
          - ezsystems/recommendation-bundle v1.0.1-rc1 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0].
          - ezsystems/recommendation-bundle v1.0.1-rc2 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0].
          - guzzlehttp/guzzle 6.2.0 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - guzzlehttp/guzzle 6.1.1 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - guzzlehttp/guzzle 6.1.0 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - guzzlehttp/guzzle 6.0.2 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - guzzlehttp/guzzle 6.0.1 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - guzzlehttp/guzzle 6.0.0 requires php >=5.5.0 -> your PHP version (5.4.16) does not satisfy that requirement.
          - Installation request for ezsystems/recommendation-bundle ^1.0.1 -> satisfiable by ezsystems/recommendation-bundle[v1.0.1, v1.0.1-rc1, v1.0.1-rc2].
      

        Activity

        Hide
        Paulo Nunes (Inactive) added a comment -

        Following installation instructions:
        if we are with PHP5.4, we end up with Installing ezsystems/recommendation-bundle (v1.0.0), but if we make the installation using php 5.5 (or 5.6), we end up with Installing ezsystems/recommendation-bundle (v1.0.1)

        If we try to force 1.0.1 on a php 5.4, then we have the error referred in description.

        Another consequence concerns EZP-25904 fix, that was only merged to 1.0.1. If we use php5.4, we don't have it.

        Show
        Paulo Nunes (Inactive) added a comment - Following installation instructions : if we are with PHP5.4, we end up with Installing ezsystems/recommendation-bundle (v1.0. 0 ) , but if we make the installation using php 5.5 (or 5.6), we end up with Installing ezsystems/recommendation-bundle (v1.0. 1 ) If we try to force 1.0. 1 on a php 5.4, then we have the error referred in description. Another consequence concerns EZP-25904 fix, that was only merged to 1.0.1. If we use php5.4, we don't have it.
        Show
        André Rømcke added a comment - Merged and tagged: https://github.com/ezsystems/EzSystemsRecommendationBundle/releases/tag/v1.0.2-rc1
        Hide
        Miguel das Neves Jacinto (Inactive) added a comment -

        QA Approved

        Show
        Miguel das Neves Jacinto (Inactive) added a comment - QA Approved

          People

          • Assignee:
            Unassigned
            Reporter:
            Miguel das Neves Jacinto (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: