Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 16.02
    • Fix Version/s: Customer request
    • Component/s: None
    • Labels:
      None
    • Environment:

      ezsystems/landing-page-fieldtype-bundle (v1.2.1)
      ezsystems/studio-ui-bundle (v1.2.2)

      Description

      The config is the same as for this one: https://jira.ez.no/browse/EZS-637

      Now we can edit the correct object, but when we click publish we end up on the wrong place.

      We ends up here: http://site.local/ez#/studio/insite/%2Fdemo%2FLandingPageLocation
      Should have ended up here: http://site.local/ez#/studio/insite/%2Fdemo%2F

      The location LandingPageLocation is the top_location of the siteaccess.

      Steps to reproduce:

      1. Prepare an eZ Studio 16.02 installation, fully updated, including:

      • ezsystems/studio-ui-bundle v1.2.2
      • ezsystems/landing-page-fieldtype-bundle v1.2.1

      2. On the admin interface, go to the "Page" section and create a new content of type "Landing Page". In my test, I called it "Home 2", and it had a location_id of 103;
      3. Edit app/config/ezplatform.yml, and create a new test siteaccess called "demo" that has the root_node set to the location_id (103) of the "Home 2" landing page. See the attached ezplatform.yml config file for reference;
      4. On the admin interface, go to the "Page" section again, select the "demo" siteaccess, and click on the "Edit" button;
      5. For testing purposes, no changes are required. Just click on "Publish". Instead of being taken back to the correct address:

      example.com/ez#/studio/insite/%2Fdemo%2F

      ...you will be re-diredted here:

      example.com/ez#/studio/insite/%2Fdemo%2FHome-2

      ...and a 404 Not Found exception will be displayed, along with a "No route found for "GET /demo/Home-2" (from "http://ezstudio120.com/ez") " error.

      Stack Trace:

      [1] Symfony\Component\HttpKernel\Exception\NotFoundHttpException: No route found for "GET /demo/Home-2" (from "http://ezstudio120.com/ez")
          at n/a
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/EventListener/RouterListener.php line 159
       
          at Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest(object(GetResponseEvent), 'kernel.request', object(TraceableEventDispatcher))
              in  line 
       
          at call_user_func(array(object(RouterListener), 'onKernelRequest'), object(GetResponseEvent), 'kernel.request', object(TraceableEventDispatcher))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/WrappedListener.php line 61
       
          at Symfony\Component\EventDispatcher\Debug\WrappedListener->__invoke(object(GetResponseEvent), 'kernel.request', object(ContainerAwareEventDispatcher))
              in  line 
       
          at call_user_func(object(WrappedListener), object(GetResponseEvent), 'kernel.request', object(ContainerAwareEventDispatcher))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php line 158
       
          at Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(array(object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener)), 'kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php line 46
       
          at Symfony\Component\EventDispatcher\EventDispatcher->dispatch('kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/TraceableEventDispatcher.php line 124
       
          at Symfony\Component\EventDispatcher\Debug\TraceableEventDispatcher->dispatch('kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 120
       
          at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), '1')
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 62
       
          at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/ContainerAwareHttpKernel.php line 69
       
          at Symfony\Component\HttpKernel\DependencyInjection\ContainerAwareHttpKernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php line 184
       
          at Symfony\Component\HttpKernel\Kernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 487
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(object(Request), true, null)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpCache/HttpCache.php line 60
       
          at Symfony\Bundle\FrameworkBundle\HttpCache\HttpCache->forward(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 444
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(object(Request), true)
              in /var/www/ezstudio120.com/vendor/friendsofsymfony/http-cache-bundle/SymfonyCache/EventDispatchingHttpCache.php line 143
       
          at FOS\HttpCacheBundle\SymfonyCache\EventDispatchingHttpCache->fetch(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 344
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 210
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/friendsofsymfony/http-cache-bundle/SymfonyCache/EventDispatchingHttpCache.php line 122
       
          at FOS\HttpCacheBundle\SymfonyCache\EventDispatchingHttpCache->handle(object(Request))
              in /var/www/ezstudio120.com/web/app.php line 66
       
      [2] Symfony\Component\Routing\Exception\ResourceNotFoundException: None of the routers in the chain matched this request
      GET /demo/Home-2 HTTP/1.1
      Accept:               text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
      Accept-Encoding:      gzip, deflate
      Accept-Language:      en-US,en;q=0.5
      Authorization:        
      Connection:           keep-alive
      Cookie:               eZSESSIDfe01ce2a7fbac8fafaed7c982a04e229=9b5v9sdin1i76l2cv1adloa737; eZSESSID82a9e4d26595c87ab6e442391d8c5bba=arfs4fjn70ftfjhstte63a8er4; eZSESSID5f02f0889301fd7be1ac972c11bf3e7d=calu5lphslml8f56u7ara61s33; eZSESSID7fa3b767c460b54a2be4d49030b349c7=9154ohn10c4tnnie62o0g7kkm3; eZSESSID98defd6ee70dfb1dea416cecdf391f58=huci8o28o3s39o3ip9hn40f6n1
      Host:                 ezstudio120.com
      Referer:              http://ezstudio120.com/ez
      Surrogate-Capability: symfony2="ESI/1.0"
      User-Agent:           Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
      X-Forwarded-For:      127.0.0.1
      X-Php-Ob-Level:       1
      X-User-Hash:          5945886524019aefc21a0e99486455ed340b913f23d342bdc6d7459b1a67eeef
       
       
          at n/a
              in /var/www/ezstudio120.com/vendor/symfony-cmf/routing/ChainRouter.php line 207
       
          at Symfony\Cmf\Component\Routing\ChainRouter->doMatch('/demo/Home-2', object(Request))
              in /var/www/ezstudio120.com/vendor/symfony-cmf/routing/ChainRouter.php line 156
       
          at Symfony\Cmf\Component\Routing\ChainRouter->matchRequest(object(Request))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/EventListener/RouterListener.php line 137
       
          at Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest(object(GetResponseEvent), 'kernel.request', object(TraceableEventDispatcher))
              in  line 
       
          at call_user_func(array(object(RouterListener), 'onKernelRequest'), object(GetResponseEvent), 'kernel.request', object(TraceableEventDispatcher))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/WrappedListener.php line 61
       
          at Symfony\Component\EventDispatcher\Debug\WrappedListener->__invoke(object(GetResponseEvent), 'kernel.request', object(ContainerAwareEventDispatcher))
              in  line 
       
          at call_user_func(object(WrappedListener), object(GetResponseEvent), 'kernel.request', object(ContainerAwareEventDispatcher))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php line 158
       
          at Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(array(object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener), object(WrappedListener)), 'kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/EventDispatcher.php line 46
       
          at Symfony\Component\EventDispatcher\EventDispatcher->dispatch('kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/EventDispatcher/Debug/TraceableEventDispatcher.php line 124
       
          at Symfony\Component\EventDispatcher\Debug\TraceableEventDispatcher->dispatch('kernel.request', object(GetResponseEvent))
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 120
       
          at Symfony\Component\HttpKernel\HttpKernel->handleRaw(object(Request), '1')
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php line 62
       
          at Symfony\Component\HttpKernel\HttpKernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/ContainerAwareHttpKernel.php line 69
       
          at Symfony\Component\HttpKernel\DependencyInjection\ContainerAwareHttpKernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php line 184
       
          at Symfony\Component\HttpKernel\Kernel->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 487
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(object(Request), true, null)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpCache/HttpCache.php line 60
       
          at Symfony\Bundle\FrameworkBundle\HttpCache\HttpCache->forward(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 444
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(object(Request), true)
              in /var/www/ezstudio120.com/vendor/friendsofsymfony/http-cache-bundle/SymfonyCache/EventDispatchingHttpCache.php line 143
       
          at FOS\HttpCacheBundle\SymfonyCache\EventDispatchingHttpCache->fetch(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 344
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(object(Request), true)
              in /var/www/ezstudio120.com/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpCache/HttpCache.php line 210
       
          at Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(object(Request), '1', true)
              in /var/www/ezstudio120.com/vendor/friendsofsymfony/http-cache-bundle/SymfonyCache/EventDispatchingHttpCache.php line 122
       
          at FOS\HttpCacheBundle\SymfonyCache\EventDispatchingHttpCache->handle(object(Request))
              in /var/www/ezstudio120.com/web/app.php line 66
      

        Issue Links

          Activity

          Sławomir Uchto added a comment - - edited
          Sławomir Uchto added a comment - - edited

          Apologize, PR was closed due to wrong merge target and recreated moment later, but on different link.

          There are two Pull Requests that fix this issue, both required.

          Pull Request: https://github.com/ezsystems/StudioUIBundle/pull/528
          Commit: https://github.com/ezsystems/StudioUIBundle/pull/528/commits/b2408e75a7383fba8d55b3a3b72f21115633a24e
          Commit hash: b2408e75a7383fba8d55b3a3b72f21115633a24e

          Pull Request: https://github.com/ezsystems/StudioUIBundle/pull/530
          Commit: https://github.com/ezsystems/StudioUIBundle/pull/530/commits/915e2ebe2c6086c160d347762ddd6d630b3765fd
          Commit hash: 915e2ebe2c6086c160d347762ddd6d630b3765fd

          Commit patches should be applied in order: b2408e75a7383fba8d55b3a3b72f21115633a24e first and then 915e2ebe2c6086c160d347762ddd6d630b3765fd

          (this will also fix EZS-696 and EZS-697)

          Michał Szołtysek added a comment -

          QA Approved with studio v1.2.2.


            People

            • Assignee:
              Unassigned
              Reporter:
              Vangen Plotz
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: