Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-312

Cogwheel stuck when creating "Landing Page"

    XMLWordPrintable

    Details

      Description

      Often, but not always the behat tests will fail ( actually get stuck ) on the sentence "Given I create a Landing Page".

      What the behat tests actually do is:
      #1 Login to /ez as admin
      #2 Click "Page" in top menu
      #3 Click "Siteaccess" demo_site
      #4 Click "+ Create" button
      #5 Click "Landing Page"
      #6 Then the "Select a Layout" window appears, but it remains grayed and the Cogwheel rolling forever.

      As mentioned this happends quite often when running behat tests

      bin/behat --colors --profile studioui --tags common
      

      But the funny thing is that have only been able to reproduce it manually in a browser once....I had firebug running, XHR tab showed no failed requests so I suspect a race condition in some javascript...?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              vidar.langseid@ez.no Vidar Langseid
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 2 hours
                  2d 2h