Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-2914

Custom inline style does not save when editor directly clicks Publish button

    XMLWordPrintable

    Details

      Description

      FINDING THE ISSUE:

      Some editors complained that they were setting the inline style to some words in the richtext and publishing the content, although their inline styles were not being saved. They also said that doesn't happen all the time which makes the issue not easy to be reproduced.

       

      WHAT WE HAVE FOUND SO FAR

      Changing the inline style in the richtext attributes doesn't update the textarea of the richtext, as you may see in the following image:

      If the editors click on the publish button, the textarea doesn't have the custom style information yet, so the attribute will be saved but the custom style is missing.

      I have noticed that the textarea is updated when any object in the page gets the focus, or even when you hover the richtext area. Thus, to reproduce this error, set the custom style and avoid to hover the richtext area or click on any element which is not the publish button. You may see that the inline style will not be saved.

       

      To illustrate that, please see the video in the link below:

      https://www.loom.com/share/4dd2eddd50fa427a80956226b6e6beb6

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            paulo@mugo.ca Paulo Valle
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: