Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-1964

Landing page editor not working when Map/Uri is used

    XMLWordPrintable

    Details

      Description

      Landing page doesn't work when you use Map\URI as matcher.

      Here are the steps to reproduce

      • Do a clean ezplatform v2.1 install with studio-clean package
      • Leave the siteaccess config part in ezplatform.yml like the following
            siteaccess:
                list: [site, admin]
                groups:
                    site_group: [site]
        
                    # WARNING: Do not remove or rename this group.
                    # It's used to distinguish common siteaccesses from admin ones.
                    # In case of multisite with multiple admin panels, remember to add any additional admin siteaccess to this group.
                    admin_group: [admin]
                default_siteaccess: site
                match:
                    Map\URI:
                        foo: site
                        admin: admin
        

      (Note Map\URI thing is the only change).

      Now enter the admin interface and try to use page editor with the homepage.

      At some point a request is done to

      http://[host]/studio/urlaliasinfo?url=%2Ffoo&siteAccessName=site
      

      and this throws a 404 error

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              desorden Carlos Revillo
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: