Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-1806

Unable to install recommendation bundle ^2.0 on ee-demo LTS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Invalid
    • Affects Version/s: 1.7.6
    • Fix Version/s: None
    • Component/s: Studio Demo Bundle
    • Labels:
      None

      Description

      Unable to install recommendation bundle ^2.0 on ee-demo LTS (1.7.6)
      ezplatform-ee-demo repo has dependency (https://github.com/ezsystems/ezplatform-ee-demo/blob/v1.7.6/composer.json#L60)

      "ezsystems/ezstudio-personalized-block": "~1.0.0",

      and it should be changed to

      "ezsystems/ezstudio-personalized-block": "^1.0",

      to be able to install 1.0 and >1.0

      ezstudio-personalized-block:

      version composer
      v1.0.1
        "ezsystems/recommendation-bundle": "^1.0"
      v1.1.0
       "ezsystems/recommendation-bundle": "^1.0|^2.0" 

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            damian.zabawa@ez.no Damian Zabawa
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: